Tutorial

DAW TÜV - Latenzkompensation

Ein Audiosystem auf Basis eines Computers benötigt Rechenzeit um die Audodaten zu bearbeiten. Dieser Zeitversatz muß ausgeglichen werden.

Latenzen entstehen an verschiedenen Stellen im System. Bei der Aufnahme muß die i/0 Latenz des Interfaces und die Treiberlatenz nach der Aufnahme kompensiert werden.

Die Recording Software schiebt nach der Aufnahme das Audiofile einige Samples nach vorne um die Aufnahme an der richtigen Stelle abzuspielen.

Die Größe dieses Zeitversatz wird der DAW vom Audiotreiber des Interfaces gemeldet.

Die Inputlatenzkompensation muß nach der Aufnahme diesen Wert für die Anpassung nutzen.

Aber wie genau meldet das Audiointerface seine Latenz? Unter Logic X meldet das Propellerheads Interface Balance 48 Samples zu viel Versatz, so daß das aufgenommen File zu früh in der Timeline landet.

Logic und auch Cubase geben aber dem Anwender die Möglichkeit den Versatz manuell nachzujustieren.

Mit einem Spiel im Hintergrund und offenem Browserfenster läßt sich der Logic X Latenzausgleich in die Irre führen. Das File landet vor der eins in der Timeline.

Weitere Folgen zum Thema in Kürze.

Download: > HD > medium >small 

02.09.2013 - Software

Dein Kommentar

  1. #22 MSchmitt schrieb am 09.10.2016
    Naja also,
    das ganze ist zwar schon etwas älter aber dennoch,
    Bevor man also einen TÜV Test macht, sollte man wissen was man tut und wo man an der DAW stellen kann.

    Hier werden Äpfel mit Birnen verglichen.
    Die REINE Input Latenz kann man so nicht messen.

    Wenn die DAW das Signal ausgibt und mittels Loopback aufnimmt misst man immer die Roundtrip-Latenz .
    D.h. output Latenz = DAW -> Plugin-> Treiber -> Interface
    UND die
    input Latenz = Interface -> Treiber -> Plugin -> DAW

    Der Grund für eine negative Input Latenz ist NICHT das der Treiber überkompensiert, sondern das der Audiooutput bei verschiedenen Puffergrüßen und Plugins verzögert wird, was dann so aussieht als ob der Input überkompensiert wird.

    Die DAW kann nicht wissen wie die Latenz durch andere Programme / Treiber oder Plugins beeinflusst wird, es könnte ja z.B. gewünscht sein das ein Plugin das Signal verzögert ausgibt.

    Übrigens macht man das nicht so.

    Es gibt für den Loopbacktest ein Messplugin Utility - I/O dann Ping clicken diesen Messwert mit umgekehrten Vorzeichen in den Latenzausgleich packen .. Fertig.
    Und unter Einstellungen -> Audio -> Allgemein kann man die Plugin Latenz anpassen.

    Liebe Grüße
    aus Frankfurt
  2. #21 JeZe schrieb am 14.09.2013
    Hi NonEric - was Du beim Phasentest immer auch berücksichtigen musst ist dei Lautstärke. Wenn das aufgenommene Signal durch ein Interface mit Vorverstärker geht ist ja nicht automatisch davon auszugehen, dass die aufgenommene Lautstärke exakt der des Ausgangs entspricht.
  3. #20 TonyR schrieb am 05.09.2013
    Also bei mir mit dem AVID I/O verändert sich die Latenz bei jeder Umstellung der Buffer Size, das ist schon ganz schön nervig! Mit der Lynx Karte und Wandler stimmen die Angaben immer es läuft wie es soll.

    Sehr schade!!! Liegt nicht an Logic sondern wohl an den AVID Treibern.

  4. #19 Daniel Meuser schrieb am 05.09.2013
    Hey;
    Danke erstmal für den Test. Ich habe bei mir die Tests gemacht und konnte das Ergebnis leider nicht reproduzieren. Getestet habe ich auf einem 2010er mac pro mit logic 9 und einem FF 800. Es könnte also tatsächlich am Audiointerface/dessen Treiber liegen. Aber ich bin trotzdem etwas verunsichert... wäre schon wenn man dazu nochmal was sagen könnte.
  5. #18 Non_Eric schrieb am 04.09.2013
    Hallo Leute,
    in der Zwischenzeit weiß ich wie ich den Input Latenzausgleich bei Logic aus dem Tritt bringen kann, es hat aber nix mit den Hintergrundanwendungen zu tuen.
    Ausserdem habe ich auch mal Studio One und Tracktion gecheckt und auch ein anderes Interface ausprobiert. Alles demnächst hier in Teil 2 zu sehen.
    Keins der drei Programm schafft den Latenzausgleich nach der Aufnahme immer fehlerfrei.
  6. #17 Ruhri schrieb am 04.09.2013
    Hi,

    hier ist eine einfache Lösung zu finden, wie man die Latenz ausgleicht - bezieht sich zwar auch L9, geht aber auch mit LX:

    http://www.youtube.com/watch?v=gQUngLB5mWg

    Zu den Hintergrundanwendungen:
    Welcher Profi lässt bei Produktionen im Hintergrund youtube-Filme und andere Anwendungen laufen??? Diesen Test möchte ich gerne mal mit anderen DAWs sehen;)

    Ruhri
  7. #16 Gerry Fischer schrieb am 04.09.2013
    Hallo Non Eric,

    danke für diesen Test, es macht beim Grossteil meiner Musik/Workflow nicht viel aus aber ich hatte ja auch noch gar nicht daran gedacht so etwas zu checken :-)

    Nun habe ich die Verzögerung eingestellt und werde dieses auch bei künftigen Produktionen berücksichtigen.

    LG Gerry Fischer
    www.gerry-fischer.at
  8. #15 EDUARDO schrieb am 03.09.2013
    Bei mir (fireface uff) hat alles bestens funktioniert mit cpu Auslastung 20 bis 27 porcent drummer geöffnet plus midifile mit Kontakt Instrumenten.
    Aufnahme von audio spur zu eine andere audio spur (no bouncing) haar genau auf den grid.
    Es ligt an audio interface
    sorry für mein deutsch
    alles liebe
    Eduardo
  9. #14 Kirk Monteux schrieb am 03.09.2013
    Also ich hatte mich noch nie so technokratisch mit der Latenz von Logic beschäftigt. Es war für mich musikalisch und technisch alles in Ordnung und das von 1.0 bis heute mit X. Selbst der Umstieg von Logic mit einer ProTools Hardware zur native war nie ein Problem weder für mich (auch Gitarrist) noch für andere auch Vocalisten fühlten sich pudelwohl in meinem Studio. Und das bei rund 500 Produktionen bis Heute.

    Ich fand deinen Test aber trotzdem Interessant und habe ihn mal bei mir genauso nachvollzogen. Ich konnte keine Probleme finden Phasenauslöschung war auf dem Bus perfekt allerdings natürlich nur bei exakt gleichem Pegel. Und was noch viel wichtiger ist:

    Das rerecording über das Audio-Interface war kein Problem.

    Es scheint das der Treiber meines Motu 896 MK3 korrekte Informationen liefert. Ich arbeite sehr viel mit analogen outboards die ich mit dem I/O Plugin in den Audiokanal des Logic einbinde. Das hat eine geniale Funktion und zwar nicht erst seit X da kannste die I/O Verbindung mit einem "Ping" durchmessen und Logic setzt den Versatz sample genau. Und hier wird nicht nur die Latenz des Audio Interface erfasst sondern auch die Latenz aller anderen momentan angeschlossener Geräte.
  10. #13 Latenzo schrieb am 03.09.2013
    http://www.youtube.com/watch?v=gQUngLB5mWg
  11. #12 Uwe schrieb am 03.09.2013
    Hallo Non Eric,
    so berechnest du nicht die latenz sondern den aufnahmeversatz, das sind doch zwei recht unterschiedliche dinge. Und ich muß meinen Vorrednern rechte geben, die Lautstärke muß exakt gleich sein. Ansonsten war der Test sehr aufschlußreich. Habe Pro Tools und Logig x. Pro Tools 0 Aufnahmeversatz, Logic x unterschiedlich, abhängig vom Interface.
  12. #11 Roland schrieb am 02.09.2013
    Hallo Non Eric
    Super-Latenztest den du mit Logic 10 gemacht hast.
    Bitte sage Tsching dass er genau die gleichen Tests mal mit Cubase 7 machen soll. Bin gespannt wie ein Geigenbogen.
  13. #10 René schrieb am 02.09.2013
    Lieber Non Eric!

    Wie einer meiner Vorredner schon bemerkt hat, müssen beim Bus-Test alle Fader und auch Send-Regler natürlich auf 0 dB stehen (bzw. auf gleicher Lautstärke). Dann funktioniert das einwandfrei: es ist absolut nichts zu hören.

    Den Audiotreiber nachzukorrigieren, ist wahrscheinlich bei nicht absoluten Profisystemen auch normal, und eine sehr gute Sache bei Logic. Damit kann man dann wirklich alle Latenzen ausgleichen. Aber auch da kann man das nur testen, wenn alle Pegel absolut gleich sind. Wenn man ganz wenig hört, liegt es aller Wahrscheinlichkeit auch daran, dass das eben nicht der Fall ist.

    Und dass bei mehr Hintergrundanwendungen die Audioperformance leidet, ist denke ich, auch eine ganz normale physikalische Erscheinung. Man sollte das ja sowieo eher vermeiden.

    Zum Schluss noch ein großes Kompliment an Deinen Kanal - ich schau regelmäßig, hab schon sehr viel gelernt und freue mich jedes Mal auf die nächste Sendung!

    Mit besten Grüßen aus Österreich,
    René
  14. #9 Gunnar schrieb am 02.09.2013
    Sehr schöne Sendung.
    Werde das ganze mal mit meinem Cubase 7 ausprobieren.
  15. #8 Frank Arnold schrieb am 02.09.2013
    Interessanter Test aber noch bisschen ausbaufähig ;)
    Du hättest mal noch eine weitere DAW als Vergleich nehmen können, um zu sehen ob es wirklich eine falsche Latenzmeldung vom Treiber ist oder ein Fehler innerhalb von Logic. Cubase wird z.B. im allgemeinen eine sehr gute Latenzkompensation nachgesagt, wäre sicherlich ein Kandidat zum Vergleich gewesen (oder eine der anderen DAWs wie Studio One, Ableton Live)

    Interessant ist auch wenn noch externe Hardware über Midi eingebunden wird. Einige Midi Interfaces oder auch Geräte die Midi über USB anbieten sind so extrem schlecht im Midi Timing das alleine dadurch der Versatz extrem hoch sein kann. Wenn dazu noch kontinuierliche Daten wie Midi Clock kommen kann es richtig schlimm werden.
    In dem Zusammenhang fallen auch die Einspielkeyboards ins Gewicht. Wenn man was einspielt und die Noten immer total versetzt aufgenommen werden muss es nicht unbedingt am eigenen Unvermögen liegen. Das kann durchaus auch ein Midi Problem sein.
    Für Midi direkt zum Testen gibt es aber auch kostenlose Tools die zumindest Jitter und so Sachen des Midi Interface messen können (läuft dann auch über einen Schleifentest, also Ein und Ausgang verbunden).

    Wie auch immer.. das mal zu testen macht sicherlich Sinn. Diesen Test könntest du sicherlich noch etwas ausbauen, mit 2-3 bekannten DAWs um da vielleicht auch Unterschiede innerhalb der DAWs zu sehen. Dann würde ich auch noch ein anderes Audio Interface als Vergleich nehmen (RME hat z.B. was Latenz und Treiber anbelangt so ziemlich mit den besten Ruf).
  16. #7 Non_Eric schrieb am 02.09.2013
    Hi Ingo,
    ja der Pegel ist entscheidend. Du kannst den Pegel auch anpassen, bis die Auslöschungen am Größten sind, wen Du keine klare Referenz hast.
    Non Eric
  17. #6 Peter schrieb am 02.09.2013
    Der Ansatz was schon fast richtig und auch die Vorgehensweise, aber…. .

    Leiber NonEric, die Überschrift “DAW TÜV – Latenzkompensation“
    ist definitiv unpassend ausgefallen, richtig wäre nämlich:
    “Logic X TÜV – Latenzkompensation“

    Auch wäre an dieser Stelle nicht unwichtig gewesen mal zu analisieren, wie verhält sich die Latenz beim Einsatz von leistungshungrigen Plugins.
    Zumindest aber hätte ich erwartet, dass wenigstens Logic X gegen Cubase bezüglich Latenzstabilität durchleuchtet wird, schade!

    Ich habe einen ähnlichen Latenztest mit Cubase und Samplitude durchgeführt und solche gravierenden Probleme wie hier im Ligic X Latenztest nicht feststellen können.
    Man kann eigentlich nur hoffen, dass die hier im Test auftretenden Latenzkompensationsprobleme vom Treiber des Propellerheads Interface Balance verursacht wurden.
    Sollte nämlich die interne Latenzkompensation in Ligic X diesen Versatz verursachen, so wäre das ein klares Bekenntnis dazu, dass Logic X nicht wirklich ein ernstzunehmendes, professionelles DAW Tool sein kann.
    Zum glück aber bietet der Markt hier seit (seit Jahren) deutlich besseres an.

    Eigentlich schade, denn die optische Aufmachung ist nicht nur angenehmer anzuschauen, sondern auch weniger verspielt als bei Cubase und vielen anderen DAW’s.
  18. #5 crispy schrieb am 02.09.2013
    sollten nicht die lautstärken der verglichenen tracks gleich sein um eine auslöschung zu erzeugen?
  19. #4 Johannes schrieb am 02.09.2013
    hallo non eric

    ein sehr sinnvoller test den du hier gemacht hast! würde dich gerne darauf hinweisen, dass als du die Bus latenz gecheckt hast, hast du über den aux poti +0,4 auf den bus geschickt... darum hat sich die spur wahrscheinlich nicht 100% ausgelöscht! wäre nochmal zu checken...

  20. #3 Ingo schrieb am 02.09.2013
    Hallo, wie immer eine richtig gute Sendung.

    Mir ist dazu noch eingefallen, dass sich die Pegel beim Phase-Invert-Check tatsächlich nur dann auslöschen, wenn die Lautstärke beider Signale identisch ist.

    Das könnte beim Loop-Back-Test je nach Einstellung der Input-Lautstärke am Interface eventuell nicht der Fall gewesen sein, oder habt Ihr darauf geachtet? Ansonsten sind die Testergebnisse schon beeindruckend.

    Beste Grüße,
    Ingo
  21. #2 feldmann schrieb am 02.09.2013
    Hi, der Latenz TÜV-Test war sehr interessant! Ich werde versuchen, das mit meinem Programm Magix Music Studio 2013 nachzubilden und hoffentlich erlebe ich da nicht eine böse Überraschung, da ich sonst doch wieder auf Reason7 zurückgreifen müsste.
    Macht bitte weiter mit euren Stresstests bzgl. DAWs, damit man nicht nur von coolen Werbesprüchen und geiler Optik in seiner Kaufentscheidung beeinflusst wird.
    hfeldmann
  22. #1 carsten schrieb am 02.09.2013
    Der Test ist eine super Idee! Dass das noch keine Audio-Seite gemacht hat, ist wirklilch erstaunlich. Da wird das Internet rauf und runter von Feinzeichnungen in den Höhen und besserem "Summing" bei DAW's geredet. Aber so einen essentiellen TÜV-Test (genau das ist er auch) mach keiner.
    Das ist etwa so, als wenn bei einem Auto die Farbnuance der Inneneinrichtung diskutiert wird, aber die kaputten Bremsen nicht interessieren.

    Ich bin mal wieder von Musotalk beeindruckt. Ihr kommt immer so "Lowtechig" (<- ist das ein Wort, oder bilde ich mir das nur ein?) daher, aber das ist eigentlich nur gute Erdverbundenheit. Mit vielen, möglicht komplizierten Worten etwas beschreiben, das man selber nicht richtig versteht, überlasst Ihr anderen.

Weitere Videos